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1. Overview
Melobase is a creativity tool for musicians. It provides a complete solution for creating or
recording your improvisation sessions on the keyboard and for discovering new musical ideas
by listening to and organizing your sequences. Your sequences can then be edited in order to
improve the content of your database, and you can export your favorite sequences as standard
MIDI files.
An overview of the user interface is presented here:
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At the left of the screen, the list of sequences and folders in your database is presented. Initially,
there are no sequences in your database, therefore the list will be empty. The list will be
populated when new sequences are being recorded, or when adding a new empty sequence.
At the top in the tool bar, the playback and record controls and the sequencer status are present.
In order to add a new sequence in your database, you may want to record a new one by pressing
the record button. Next to these controls is a button for converting the selected sequence from
a single track format to a multiple tracks format or vice-versa. At the right of the tool bar, a
sequencer status indicator is present.
At the bottom of the screen, the studio controls are shown. Two zones are available: the upper
and the lower zones. The split controls allow to use the left portion of your MIDI keyboard for
the lower zone. A master level slider is also present in order to set the global volume at the
output when the internal synthesizer is used.

2. Play
You may play either from a MIDI keyboard or from your computer keyboard. In order to select
the desired MIDI keyboard, you will have to select the desired MIDI input device. Refer to the
Preferences section for more details about how to configure the MIDI keyboard input.
The following keys are available when playing with the computer keyboard:

• A, W, S, E, D, F, T, G, Y, H, U and J for playing notes;
• Z and X for decreasing and increasing the octave respectively;
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• C and V for decreasing and increasing the velocity respectively;
• Q for toggling the sustain state.
These keys are illustrated here:

Take note that the key mapping has been designed for a QWERTY keyboard type only. The user
may have to switch to such type of keyboard in order to easily play using the computer keyboard.

3. Record
The tap-tempo is an important feature of Melobase in order to quickly capture your musical
idea. The recording session will stop automatically after four (4) seconds of inactivity, unless
the user decides to configure it differently under the Preferences.
In order to start a recording session, select Control → Record or press the Record button. The
following tap-tempo panel will then appear:

In order to provide the tempo, perform the following steps:

• Press the right arrow key on your computer keyboard to indicate the first major beat;
• Press the left arrow key on your computer keyboard one or multiple times to indicate the
other beats of a single measure;

• Press again the right arrow key to stop the learning session and consequently start
automatically the recording session.
These steps are illustrated here for 4/4 and 3/4 time signatures:
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Other time signatures are also possible depending on the sequence of key presses performed.
Alternatively, the MIDI keyboard may be used instead of the arrow keys. The first key being
pressed on the MIDI keyboard has the same effect as the right arrow key. Any other key on the
MIDI keyboard will be equivalent to the left arrow key. There steps are illustrated here for a
3/4 time signature recording:

4. Preferences
The preferences dialog can be accessed by selecting the menu item "Tools → Options..." on
Windows, or "Melobase → Preferences..." on a Mac. The following dialog will then appear:
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The settings will be saved in order to be restored at the next execution of the application.

4.1. MIDI Input
The list of available MIDI input devices will be shown by pressing the related button. This list
is updated automatically when a new USB MIDI device is connected or removed.

4.2. MIDI Output
The list of available MIDI output devices will be shown by pressing the related button. This list
is updated automatically when a new USB MIDI device is connected or removed.

4.3. Audio Output
The list of available audio output devices will be shown by pressing the related button. After
the selection of an output audio device is done, the output audio latency will be set to a default
value. It is recommended to keep this value.
The list of available audio output devices is updated when the application is started. If you
connect a new device when the application is running, you will need to quit and restart the
application is order to see the new device.

4.4. MIDI Destination
It is possible to select either the internal synthesizer or the MIDI output device as MIDI
destination. A MIDI output device must be selected when using the MIDI output as the
destination.

4.5. Automatic Stop Recording

Page 6

Melobase Desktop 1.4 User Guide

Meldora Inc.

The recording session can be stopped automatically when all notes are released for a given
period a time. It is possible to enable or disable this feature, and also to set the inactivity period.

5. Sequencer Controls
The sequencer controls are the following:

6. Studio Controls
The studio controls are available at the bottom of the screen. Two zones are available. The split
controls are between the two zones. When the keyboard split is enabled, the left portion of the
MIDI keyboard is dedicated to the lower zone.

6.1. Zones
The controls for a zone are the following:
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The channel selection for the zone is done by clicking on the number above the module. The
standard drum kit is available on channel 10.
The instrument selection is done by clicking on the instrument selection button. A list of General
MIDI instruments will then appear. Select the desired instrument from the list.
In order to transpose the notes being submitted by either your MIDI or computer keyboard, click
on the UP or DOWN arrow. The value will either increase or decrease in steps of 12 semitones.
The level can also be set using the respective slider. The maximum output level is 0 dB (no
attenuation), and the minimum output level is -18 dB (maximum attenuation).
The balance or pan control slider is under the level slider.

6.2. Split Controls
The split controls are the following:

These controls are only available when a MIDI keyboard is connected. Refer to the Preferences
section for the selection of your MIDI input device.
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In order to enable or disable the MIDI keyboard split, click on the split button.
The split position can be set by clicking on the Set Split button. A dialog will then appear asking
you to press on the desired key on your MIDI keyboard for your split position. The notes below
the split position will be sent to the lower zone, and the notes at or above this position will be
sent to the upper zone.

6.3. MIDI Routing
The MIDI routing is the following:

The first channel at the MIDI input is dedicated for the master keyboard which can be split. The
channel is based on the currently selected channel for the upper or the lower zone. The lower
zone is only available when the keyboard split feature is enabled.
The channels 2 to 16 are not redirected.

7. Database

7.1. List of Sequences
The list of sequences in your database is shown at the left of the screen. In order to select a
sequence, click on the desired item. The item will become highlighted.
The information presented for each item of the list are the following:
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The status is shown at the left. It shows either if the sequence is new (not yet played), or if the
rating is negative (below the trash level). The creation date and time, the rating and the name
are also shown.
In order to set the rating of a sequence, select the sequence first and then drag the mouse on the
rating region in order to select the number of stars. It is also possible to set the rating by selecting
Sequences → Rate → value, where value is the desired rating value for the selected sequence(s).
In order to set or change the name of a sequence, select the desired sequence in the list and
press the Return key.
It is possible to select multiple sequences by holding the Command key under macOS or the
Control key under Windows.
Filters are available at the top of the list. The filter controls are the following:

7.2. List of Folders
In order to show the list of folders, select View → Show Folders under macOS, or Window
→ Show Folders under Windows. Two root folders are present: Sequences and Trash. The
Sequences folder is the main folder containing all your sequences. It is possible to create
subfolders inside the Sequences and any of its subfolders by first selecting the desired parent
folder and then performing Sequences → New Subfolder.

Page 10

Melobase Desktop 1.4 User Guide

Meldora Inc.

7.3. Drag & Drop Operations
In order to move a sequence from one folder to another one, make sure that the destination folder
is visible and then perform a drag & and drop operation from the sequence to the desired folder.
In order to move a folder to another one, make sure that the destination folder is visible and then
perform a drag & drop operation of the folder to the desired destination folder.

7.4. Actions
Special care has been taken in order to ease-up the organization of your music sequences. The
features related to this need are the following:

• A rating value up to five (5) stars for each sequence, a negative rating being possible for
future deletion;

•
•
•
•

A filter for viewing only the sequences with a minimum rating;
The ability to promote or demote all played sequences by adding or removing one star;
The ability to set as played all your sequences;
The ability to move a sequence to the Trash.

These features are depicted by the following image:
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In order to promote all your sequences, select Sequences → Promote All. In order to demote all
your sequences, select Sequences → Demote All. It is possible to move to trash a sequence by
performing the operation Sequences → Move to Trash.
Only played sequences will be affected by a promotion or a demotion operation. If sequences
with no stars are to be demoted, the rating will become negative and they will be flagged for
deletion.

7.5. Create a New Sequence
In order to create a new sequence, select Sequences → New. The following dialog will then
appear:
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Enter the name, a time signature and select a tempo value for your new sequence. The new
sequence will have initially 10 bars. In order to change the length of your sequence, you will
need to move the End of Track event. See the section Sequence Edition for more details.

7.6. Importation of a Sequence
In order to import one or multiple sequences as standard MIDI files, select File → MIDI Import.
It is also possible to import the sequences by dragging the files from the Finder under macOS
or Explorer under Windows to the Melobase window.

7.7. Exportation of a Sequence
In order to export a sequence as a standard MIDI file, select the desired sequence and select
File → MIDI Export.
In order to export a sequence as an audio file in AIFF format, select the desired sequence and
select File → Audio Export. A progress bar will appear during the rendering process.

8. Sequence Edition

8.1. MIDI Types
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Melobase supports the MIDI types 0 and 1 for a given sequence. The type 0 is a single track
format, and the type 1 is a multiple tracks format. By default, a new sequence is of type 0. It is
possible to convert a sequence to from a single track format to a multiple tracks format using
Sequences → Convert to Multiple Tracks, or use the conversion button in the tool bar.
After the conversion from a single track to a multiple tracks format, the name of the tracks will
be set based on the instrument name, and each track will have its own channel.

8.2. Tracks
The tracks are shown in an arrangement view for sequences with multiple tracks (MIDI type 1).
An example of an arrangement view containing three tracks is shown here:

The piano roll view will display the content of the selected track. The header of each track is
shown here:

Page 14

Melobase Desktop 1.4 User Guide

Meldora Inc.

Each track has its own channel assignment unless the selection is MULTI.
In order to record one or multiple tracks, click the ARM button on the desired tracks to record
and then press the record button. Note that the inactivity detection is always disabled when
recording one or multiple armed tracks.
It is possible to mute one or multiple tracks using the MUTE button. In order to only hear one
track at a time, use the SOLO button.
Each track has its own name. It is possible to change the name of the track by selecting it and
then pressing Enter. Note that although the name of the track is typically the instrument name,
changing the name of the track will have no impact on the actual instrument associated to it. In
order to change the instrument of a given track, the program change event must be modified.
By default, the first track is hidden. This track contains only time signature and tempo events.
No note events can be added to the first track. In order to show the first track, click on the "First
Track" check box.

8.3. Piano Roll
In order to edit a sequence, select the desired item from the list at the left. The following tools
will be available at the top of the piano roll:
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The arrow is the default tool for performing the following actions:

• Setting the cursor position in the piano roll;
• Moving the selected notes;
• Resizing the selected notes.
Only the selected notes can be edited. The selection tool represented by the rectangle allows
the selection of notes on the piano roll by clicking and dragging the mouse over the desired
region. The selected notes will be highlighted, and a resize handle will appear at the right of
the selected items as shown here:

In order to quickly toggle between the arrow and selection tools, the selection tool will be active
when the Control key is pressed, and the arrow tool will automatically become active when the
key is released.
Another solution for speeding-up the edition task is to use the right mouse button for selecting a
region on the piano roll. In order to do so, right click and drag the mouse for selecting a region
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on the piano roll. When the button is released, the arrow tool will automatically become active
for editing the selected events.
You may use the Shift key to add to the previous selection.
In order to delete the selected events, select Edit → Delete or press the Delete key.
In order to draw notes, select the drawing tool, click on the piano roll, hold the button down
and move the mouse until the desired length is obtained. The default properties for the drawn
notes are based on the following:

When pasting events, if all the events in the clipboard have the same channel, the channel of
the pasted events will be the currently selected one.
In order to align the notes to the grid at the current zoom level, select the events on the piano
roll and press the Quantize button. For notes, only the position will be modified in order to be
aligned to the nearest grid line. The length of the notes will not be affected by this operation.
The modifications will be saved automatically in the database. There are no required actions
for saving your modifications.
A zoom slider for the piano roll is also available. Subdivisions will appear at higher zoom levels.
Under the piano roll header, the meta events are present as shown here:
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You may add a time signature meta event using the drawing tool. The value may then be changed
by changing its properties as explained below. In order to change the total length of the sequence,
select and move the end of track event.
Two edition panes initially hidden can be shown using the following buttons:

The right pane shows the properties of the currently selected event(s). The bottom pane shows
the meta and controller events. The following meta and controller events are available:
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9. Synchronization with the Mobile Version
The embedded server for synchronizing your sequences with the mobile version of Melobase
is started automatically at application launch, and will stay active as long as the application is
running.
After emptying the Trash, the permanently deleted sequences will no longer be tracked by the
synchronization process. Therefore, in order to prevent deleted sequences from being restored
during the synchronization, it is suggested to perform a synchronization before emptying the
Trash on each device.

10. MIDI Implementation
Table 10.1: Channel Events
Type

Status (HEX)

Second (HEX)

Third (HEX)

Notes

Note ON

1001 nnnn (9n)

0kkk kkkk (kk)

0vvv vvvv (vv)

n: channel, k: pitch, v:
velocity

Note OFF

1000 nnnn (8n)

0kkk kkkk (kk)

0xxx xxxx (xx)

n: channel, k: pitch, x:
not interpreted

Pitch Bend

1110 nnnn (En)

0lll llll (ll)

0mmm mmmm (mm) n: channel, l: LSB
value, m: MSB value

Program Change

1100 nnnn (Cn)

0ppp pppp (pp)

None

Table 10.2: Controller Events
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Second (HEX)

Third (HEX)

Notes

Damper Pedal

1011 nnnn (Bn)

0100 0000 (40)

0vvv vvvv (vv)

n: channel, v: value

Modulation Wheel

1011 nnnn (Bn)

0000 0001 (01)

0vvv vvvv (vv)

n: channel, v: value

Volume

1011 nnnn (Bn)

0000 0111 (07)

0vvv vvvv (vv)

n: channel, v: value

Pan

1011 nnnn (Bn)

0000 1010 (0A)

0vvv vvvv (vv)

n: channel, v: value

Start

1011 nnnn (Bn)

0111 0010 (72)

0vvv vvvv (vv)

n: channel, v: value
(if v < 64, will toggle
record mode)

Stop

1011 nnnn (Bn)

0111 0011 (73)

0vvv vvvv (vv)

n: channel, v: value
(if v < 64, will toggle
record mode)
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